Greatminds.org is down
Incident Report for Great Minds
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 16:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2021 - 16:50 EDT
Update
We are continuing to investigate this issue.
Posted Sep 14, 2021 - 15:53 EDT
Update
We are continuing to investigate this issue.
Posted Sep 14, 2021 - 15:24 EDT
Investigating
We are currently investigating the greatminds.org website being down
Posted Sep 14, 2021 - 15:24 EDT
This incident affected: Eureka Math Navigator, PhD Science Digital Teacher Edition, Website, and Wit & Wisdom Digital Teacher Edition.