AWS Outage and Great Minds Impact

Incident Report for Great Minds

Resolved

Working with AWS support we have resolved the issue as of 1am Eastern today. All major functionality is restored.
Posted Oct 21, 2025 - 01:00 EDT

Identified

AWS has resolved the main underlying issue. However, there still remains an AWS issue affecting our services. We are working with Amazon Web Services support engineers to identify and resolve the issue. In the meantime users will not be able to login or use the platform.
Posted Oct 20, 2025 - 23:39 EDT

Update

We are continuing to closely monitor the situation with our cloud provider (AWS) and their ongoing outage impacting Internet services across the web. We still are seeing slowness and occasional login failures on Great Minds' digital platform and expect that to continue until AWS resolves the underlying issues.
Posted Oct 20, 2025 - 14:13 EDT

Monitoring

We are monitoring the AWS Outage and the impact on Great Minds Digital Platform. Right now, notable impact is:

- Content/Assessment interactives are not working
- Single Sign On from partners intermittently fails
- Slowness/Latency throughout the platform

If further impact is discovered we will update the status page for awareness, otherwise the larger event can be monitored here: https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 10:48 EDT
This incident affected: Digital Platform.