Eureka Math Navigator Outage
Incident Report for Great Minds
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 11:58 EDT
Monitoring
A fix has been implemented followed by testing and the issue should now be resolved. We continue to monitor this situation.
Posted Jun 30, 2022 - 11:01 EDT
Identified
The root cause for this issue has been discovered and we are working towards a solution.
Posted Jun 30, 2022 - 10:31 EDT
Update
Many customers are unable to access Eureka Math Navigator at the moment. We are investigating the issue and will continue to post updates here once they are available.

Update: This event is affecting access to Wit & Wisdom Digital Teacher Edition and PhD Science Digital Teacher Edition too. Investigation is ongoing.
Posted Jun 30, 2022 - 10:21 EDT
Investigating
Many customers are unable to access Eureka Math Navigator at the moment. We are investigating the issue and will continue to post updates here once they are available.
Posted Jun 30, 2022 - 09:59 EDT
This incident affected: Eureka Math Navigator, Wit & Wisdom Digital Teacher Edition, and PhD Science Digital Teacher Edition.