Students unable to login
Incident Report for Great Minds
Resolved
This issue has been resolved.
Posted Oct 17, 2023 - 10:28 EDT
Identified
We've identified an issue that is preventing many students from being able to login. We are currently working to resolve it.
Posted Oct 17, 2023 - 10:00 EDT
This incident affected: Affirm, Digital Platform, and in Sync.