Assessment Loading Issues

Incident Report for Great Minds

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 13:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2026 - 13:14 EDT

Investigating

The team is currently investigating an issue impacting users when trying to access the Assessments. This is being investigated with high priority and updates will follow as work progresses.
Posted Sep 11, 2026 - 13:01 EDT
This incident affected: Digital Platform.