SSL Certificate Error on digital.greatminds.org
Incident Report for Great Minds
Resolved
This incident has been resolved.
Posted Dec 06, 2021 - 16:42 EST
Monitoring
A fix has been applied and the team believes the issue to be resolved. Great Minds is performing additional testing and reviewing logs and application metrics to confirm all functionality has been restored.

Please alert support to any new access issues after the time of this post for review.
Posted Dec 06, 2021 - 14:29 EST
Update
The SSL certificate has been updated and digital.greatminds.org should no longer be presenting an error message. Authentication is still a problem for users though which the teams continue to work on to resolve this incident fully.
Posted Dec 06, 2021 - 11:33 EST
Update
The message "Your connection is not private" is shown when attempting to access digital.greatminds.org. Great Minds is currently working on the SSL certificate for this site to restore access.

We've had a delay from our 3rd party certificate provider, which is delaying our ability to restore services. The team is working with them to restore service as quickly as possible.
Posted Dec 06, 2021 - 11:04 EST
Update
The message "Your connection is not private" is shown when attempting to access digital.greatminds.org. Great Minds is currently working on the SSL certificate for this site to restore access.

The team has identified the root cause and is working to resolve it. This is estimated to be resolved within the next hour, by approximately 11:00am Eastern Time.
Posted Dec 06, 2021 - 09:56 EST
Update
The message "Your connection is not private" is shown when attempting to access digital.greatminds.org. Great Minds is currently working on the SSL certificate for this site to restore access.

The team has identified the root cause and is working to resolve it. Additional updates will be posted here each hour with a status update or when the issue is resolved, whichever comes first.
Posted Dec 06, 2021 - 08:44 EST
Identified
The message "Your connection is not private" is shown when attempting to access digital.greatminds.org. Great Minds is currently working on the SSL certificate for this site to restore access.
Posted Dec 06, 2021 - 07:53 EST
This incident affected: Affirm, Digital Platform, and in Sync.