Intermittent Errors Authenticating or Navigating Great Minds Digital Platform

Incident Report for Great Minds

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 13:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 12:44 EDT

Identified

Intermittent errors continue to occur after the first fix attempt. The team continues to investigate a permanent fix.
Posted Oct 15, 2025 - 12:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 12:18 EDT

Investigating

The Great Minds team is investigating an issue that is impacting the authentication into or navigating of the digital platform. More information will be posted as the investigation progresses.
Posted Oct 15, 2025 - 12:02 EDT
This incident affected: Digital Platform.