Short links unreachable
Incident Report for Great Minds
Resolved
The issue with short links has been resolved.
Posted Oct 20, 2021 - 10:00 EDT
Identified
We've identified an issue with short links being unreachable (witeng.link, eurmath.link, phdsci.link). The team is working to resolve this as quickly as possible.
Posted Oct 20, 2021 - 08:45 EDT
This incident affected: Supporting Services (Bitly: eurmath.link, phdsci.link, and witeng.link short URLs).