Great Minds Digital Platform Planned Maintenance for July 6th

Incident Report for Great Minds

Resolved

Maintenance work has completed and the work window is being closed.
Posted Jul 06, 2025 - 14:15 EDT

Monitoring

Scheduled maintenance is complete. All systems have been restored and are now operational. We are currently monitoring to ensure everything is functioning as expected.
Posted Jul 06, 2025 - 13:03 EDT

Investigating

Scheduled maintenance is complete. All systems have been restored and are now operational. We are currently monitoring to ensure everything is functioning as expected.
Posted Jul 06, 2025 - 13:03 EDT
This incident affected: Digital Platform.